Autor Tema: Problemas para ver el applet de GeoGebra

0 Usuarios y 1 Visitante están viendo este tema.

05 Enero, 2017, 02:26 am
Leído 2084 veces

Santusa

  • Novato
  • Mensajes: 140
  • Karma: +0/-0
  • Sexo: Femenino
Hola, cómo están todos:

Trabajo con Linux Mint 18. Tengo instalado el IcedTea-Web Plugin. El navegador Firefox lo reconoce. Sin embargo, cuando quiero ver una página como esta. Aparece el cuadro de IcedTea web, con un mensaje en la esquina inferior derecha que dice "Click here for details. An exception has occurred."

No sé como hacerlo funcionar.

Muchas gracias y cariños.

05 Enero, 2017, 09:36 am
Respuesta #1

Luis Fuentes

  • el_manco
  • Administrador
  • Mensajes: 46,782
  • País: es
  • Karma: +1/-0
  • Sexo: Masculino
Hola

 Nunca he trabajado sobre LiNuX, pero aquí se menciona un error similar:

http://askubuntu.com/questions/460543/error-running-java-web-application-with-openjdk-java7-runtime-in-ubuntu-14-04

 Y parece que lo soluciona instalando el Java de Oracle.

Saludos.

05 Enero, 2017, 04:19 pm
Respuesta #2

feriva

  • Matemático
  • Mensajes: 8,995
  • País: es
  • Karma: +1/-0
  • Sexo: Masculino
  • ¡EUKERA!... ¡UEREKA!... ¡EUREKA! (corregido)
Hola, cómo están todos:

Trabajo con Linux Mint 18. Tengo instalado el IcedTea-Web Plugin. El navegador Firefox lo reconoce. Sin embargo, cuando quiero ver una página como esta. Aparece el cuadro de IcedTea web, con un mensaje en la esquina inferior derecha que dice "Click here for details. An exception has occurred."

No sé como hacerlo funcionar.

Muchas gracias y cariños.

Hola. Yo uso Ubuntu, también de Linux, y me pone "Toque aquí para instalar Java". Siempre me ha pasado; el caso es que sí tengo Java y cuando alguna vez he tocado ahí me ha descargado un paquete que me da pereza instalar por las instrucciones, que son un lío y hay que hacer muchas cosas; y si voy a instalar al repositorio, pues eso, que dice que ya tengo Java. En cualquier caso no tardo en descargarlos y verlos.

Saludos.

05 Enero, 2017, 04:44 pm
Respuesta #3

Santusa

  • Novato
  • Mensajes: 140
  • Karma: +0/-0
  • Sexo: Femenino
Gracias el_manco y feriva.

En el enlace que puso el_manco, figuran los comandos

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java8-installer

Luego de ingresarlos por la consola, queda instalado el script de Java "oracle-java8-installer.xml", Este script sirve para instalar Oracle.
Tengo que estudiar como se ejecutan esos script, ya intente con "java oracle-java8-installer.xml" (en la consola va sin comillas) y me devuelve el mensaje:
"Error: no se ha encontrado o cargado la clase principal oracle-java8-installer.xml"
Por supuesto que el comando anterior lo ejecuto desde donde está el script.
Seguramente, java tiene otros ejecutables que hacen funcionar el script, el asunto es averiguar cual es.

Por si pasa algún experto en Java, el script es el siguiente:

Código: [Seleccionar]
<?xml version="1.0"?>
<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
<mime-type type="application/java-archive">
<comment>Java Archive</comment>
<glob pattern="*.jar"/>
</mime-type>

<mime-type type="application/x-java-jnlp-file">
<comment>Java Web Start application</comment>
<glob pattern="*.jnlp"/>
</mime-type>
</mime-info>


Hola. Yo uso Ubuntu, también de Linux, y me pone "Toque aquí para instalar Java". Siempre me ha pasado; el caso es que sí tengo Java y cuando alguna vez he tocado ahí me ha descargado un paquete que me da pereza instalar por las instrucciones, que son un lío y hay que hacer muchas cosas; y si voy a instalar al repositorio, pues eso, que dice que ya tengo Java. En cualquier caso no tardo en descargarlos y verlos.

Saludos.
A mí me pasa lo mismo para instalar el scanner de la Epson Stylus CX5600.  :)
Cariños.