Autor Tema: A veces MathJax no renderiza (vista previa, recargar la página) [Chrome]

0 Usuarios y 1 Visitante están viendo este tema.

16 Enero, 2021, 10:25 pm
Leído 299 veces

manooooh

  • $$\Large \color{#9c57a6}\pi\,\pi\,\pi\,\pi\,\pi\,\pi$$
  • Mensajes: 3,254
  • País: ar
  • Karma: +1/-0
  • Sexo: Masculino
Hola

Hace un tiempo (días diría) me viene sucediendo algo con Chrome (Versión 87.0.4280.141 (Build oficial) (64 bits)) y es que cuando estoy escribiendo un mensaje y quiero previsualizarlo, las fórmulas encerradas entre [tex][/tex] no se renderizan. Lo mismo sucede a veces cuando entro a un hilo y hay fórmulas; no se ven, sino que tengo que recargar varias veces para que se vean.

Lo acabo de probar con Edge y no me pasa lo mismo. Quizás sea porque en Chrome tengo una extensión llamada TeX All the Things que lo uso a veces, por eso jamás lo habilito salvo para ocasiones muy especiales y en sitios como https://math.stackexchange.com/ no me sucede este problema.

Aunque en Edge lo he probado 5 minutos, quizás en ese tiempo no dio a reproducir el bug, pero en Chrome recién saqué una captura como ejemplo:


[attachment id=0 msg=460441]


Ocurrió luego de que le diera al botón de Publicar.



También aprovecho a comentar algo que me pasa siempre, y es que luego de loguearme al foro estando en el índice o en cualquier hilo, me lleva a cualquier otra parte del foro (cambia la url). Es decir que lo normal sería loguearse y que no cambie de página; tengo que retroceder una página y recargar (pues al retroceder no queda "guardado" mi inicio de sesión pero al recargar sí).

¿A alguien más le sucede lo mismo? ¿Es problema del foro o mío? ¿Cómo se puede solucionar?

Gracias!!
Saludos

16 Enero, 2021, 10:33 pm
Respuesta #1

Luis Fuentes

  • el_manco
  • Administrador
  • Mensajes: 47,845
  • País: es
  • Karma: +0/-0
  • Sexo: Masculino
Hola

Hace un tiempo (días diría) me viene sucediendo algo con Chrome (Versión 87.0.4280.141 (Build oficial) (64 bits)) y es que cuando estoy escribiendo un mensaje y quiero previsualizarlo, las fórmulas encerradas entre [tex][/tex] no se renderizan. Lo mismo sucede a veces cuando entro a un hilo y hay fórmulas; no se ven, sino que tengo que recargar varias veces para que se vean.

A mi esto me ha pasado útlimamente una vez, que yo recuerde. Pero de manera muy excepcional. Publico y previsualizo mucho y casi siempre me va bien.

Citar
También aprovecho a comentar algo que me pasa siempre, y es que luego de loguearme al foro estando en el índice o en cualquier hilo, me lleva a cualquier otra parte del foro (cambia la url). Es decir que lo normal sería loguearse y que no cambie de página; tengo que retroceder una página y recargar (pues al retroceder no queda "guardado" mi inicio de sesión pero al recargar sí).

Esto si me pasa habitualmente; reconozco que no le he dado demasiada importancia.

Saludos.

16 Enero, 2021, 10:36 pm
Respuesta #2

manooooh

  • $$\Large \color{#9c57a6}\pi\,\pi\,\pi\,\pi\,\pi\,\pi$$
  • Mensajes: 3,254
  • País: ar
  • Karma: +1/-0
  • Sexo: Masculino
Hola

Ah, muchas gracias Luis, pensé que era yo solo.

¿Usas Chrome o te sucede con otro navegador? Quizás si recopilamos información de otros navegadores sea un problema del foro; sino es probable que sea problema de Chrome, pero no encuentro solución.

Saludos

17 Enero, 2021, 01:28 am
Respuesta #3

C. Enrique B. Cortés

  • $$\Large \color{#5e8d56}\pi\,\pi\,\pi$$
  • Mensajes: 224
  • País: es
  • Karma: +0/-0
    • Foro GSC
.
A) Agradecer como has montado el enunciado (una monada de post, práctico, útil, por varias razones).

B) Quizá incluso es bueno el "error" de "tener que recargar la página" cuando vas para atrás a la pág. anterior que visitaste y "no guarda el hecho de que estés ya Log-In", ya que así el regreso al estado anterior es más fidedigno, más auténtico. Y, tal como dice Luis Fuentes, a mí me pasa en todo tipo de páginas y no le doy importancia. ///  Y lo de que no te mantenga en la misma página en la que estabas antes de Log-In, puede ser una decisión del programador o configurador, ¿no?

C) En cuanto al otro tema no tengo idea -todavía soy virgen latexiano- ... mmm ... (esto ha sonado raro ... mmm ...)
____________________
-- FALTAN LAS MUJERES en muchos ámbitos sociales. Yo no me siento perteneciente al bando masculino; soy del bando de las personas. Chicas, manifestáos; no concibo charlar sobre un tema si no estáis vosotras: es impropio, casi absurdo.

-- F o r o   G S C . https://gsc.invisionzone.com  Social, abierto a TODAS las personas. Regístrate, dá señales de vida; puedo configurar ese foro a tu gusto.

17 Enero, 2021, 08:51 am
Respuesta #4

Luis Fuentes

  • el_manco
  • Administrador
  • Mensajes: 47,845
  • País: es
  • Karma: +0/-0
  • Sexo: Masculino
Hola

¿Usas Chrome o te sucede con otro navegador? Quizás si recopilamos información de otros navegadores sea un problema del foro; sino es probable que sea problema de Chrome, pero no encuentro solución.

Si, uso el Chrome. Pero insisto en que el problema que citas al renderizar el LaTeX se me ha dado de manera muy residual. Es decir yo lo he interpretado más como un fallo puntual que como uno crónico.

Saludos.

21 Enero, 2021, 11:56 pm
Respuesta #5

manooooh

  • $$\Large \color{#9c57a6}\pi\,\pi\,\pi\,\pi\,\pi\,\pi$$
  • Mensajes: 3,254
  • País: ar
  • Karma: +1/-0
  • Sexo: Masculino
Hola

Si, uso el Chrome. Pero insisto en que el problema que citas al renderizar el LaTeX se me ha dado de manera muy residual. Es decir yo lo he interpretado más como un fallo puntual que como uno crónico.

Pues a mí me pasa seguido en Chrome, que es donde tengo todas las cookies y demás cosas guardadas. Por ejemplo es molesto no poder renderizar las fórmulas cuando se previsualiza el mensaje.

Así que propongo un tratamiento moderado/urgente de este tema, si es que existe algo parecido a eso. ;)

Saludos

22 Enero, 2021, 11:31 am
Respuesta #6

Luis Fuentes

  • el_manco
  • Administrador
  • Mensajes: 47,845
  • País: es
  • Karma: +0/-0
  • Sexo: Masculino
Hola

Pues a mí me pasa seguido en Chrome, que es donde tengo todas las cookies y demás cosas guardadas. Por ejemplo es molesto no poder renderizar las fórmulas cuando se previsualiza el mensaje.

Pero si no le pasa más gente, ¿será algún problema particular?. ¿Has probado a borrar las cookies?.

Saludos.


22 Enero, 2021, 11:49 am
Respuesta #7

sugata

  • $$\Large \color{#9c57a6}\pi\,\pi\,\pi\,\pi\,\pi\,\pi$$
  • Mensajes: 2,908
  • País: es
  • Karma: +1/-0
  • Sexo: Masculino
Yo siempre uso Chrome en el móvil y ningún problema...