Autor Tema: Algoritmo pseint

0 Usuarios y 1 Visitante están viendo este tema.

16 Julio, 2021, 09:14 pm
Leído 504 veces

Berner

  • $$\Large \color{#5372a0}\pi\,\pi$$
  • Mensajes: 55
  • País: cr
  • Karma: +0/-0
Hola ¿Alguien puede darme un algoritmo para este problema  por favor? Creo que el mío está mal

Citar
Leer 100 números. Determina la media de los números positivos y la media de los números negativos.


Proceso media_numeros
Definir i,sumanega,sumaposi,num,nega,posi como entero
Definir cantiposi,cantinega como real
i<-0
sumanega<-0
sumaposi<-0
nega<-0
suma<-0
Mientras i<=100 Hacer
Escribir 'Digite el numero',i
Leer num
Si num<0 entonces
sumanega<-sumanega+num
nega<-nega+1
Sino
sumaposi<-sumaposi+num
posi<-posi+1
Fin Si
i<-i+1
FinMientras
cantiposi<-sumaposi/posi
cantinega<-sumanega/nega
Escribir 'La media de los negativos es  ',cantinega
Escribir 'La media de los positivos es ',cantiposi
FinProceso

16 Julio, 2021, 10:11 pm
Respuesta #1

ingmarov

  • Moderador Global
  • Mensajes: 5,193
  • País: hn
  • Karma: +0/-0
  • Sexo: Masculino
Hola

Hola alguien puede darme un algoritmo para este problema  por favor creo que el mio esta mal

Proceso media_numeros
Definir i,sumanega,sumaposi,num,nega,posi como entero
Definir cantiposi,cantinega como real
i<-0
sumanega<-0
sumaposi<-0
nega<-0
suma<-0
Mientras i<=100 Hacer
Escribir 'Digite el numero',i
Leer num
Si num<0 entonces
sumanega<-sumanega+num
nega<-nega+1
Sino
sumaposi<-sumaposi+num
posi<-posi+1
Fin Si
i<-i+1
FinMientras
cantiposi<-sumaposi/posi
cantinega<-sumanega/nega
Escribir 'La media de los negativos es  ',cantinega
Escribir 'La media de los positivos es ',cantiposi
FinProceso

¿Qué error te da?

¿Estás inicializando la variable "posi" en tu código?

Saludos
No te confíes, revisa lo que escribo. Yo también me equivoco.
Odio el autocorrector de Android...

16 Julio, 2021, 10:18 pm
Respuesta #2

mathtruco

  • Moderador Global
  • Mensajes: 5,354
  • País: cl
  • Karma: +0/-0
  • Sexo: Masculino
  • El gran profesor inspira
Creo que la variable suma que defines como cero debe ser posi.

- Estás tomando los casos cuando el número ingresado es negativo o positivo, falta el caso cuando es cero.
- Falta considerar el caso cuando no hay números positivos y el caso cuando no hay números negativos. En esos casos nega o posi serán cero y estarás dividiendo por cero.

Aparte de eso lo veo correcto, has resuelto bien la parte más complicada del problema.

Edité tu mensaje añadiendo el enunciado del problema que habías puesto en una imagen. Para próximos mensajes evita colocar imágenes con enunciados o procedimientos.